Temperature reading off - calibration possible?

For general discussion of the UltraSmartCharger
User avatar
MartinB
Posts: 14
Joined: Sat Jun 18, 2016 8:46 am
Contact:

Re: Temperature reading off - calibration possible?

Postby MartinB » Tue Jun 21, 2016 7:59 am

Hi Mark,

I did, as you requested.

USB
ch1 ch2
ISP
+ 000
- 000

I measured between the bold marked pads.

Reading charger 1 (COM5): 3,03 V
Reading charger 2 (COM6): jumps between 3,01 V and 3,02 V; eventually stabilizes at 3,02 V

I have to admit, that my multimeter is not a good choice for that, since it was intended for battery measurement (it has 2 V, 20V, 200V, ... ranges).
So I had to go with the 20V setting, possibly leading to a big error in measurement. At least the error should be the same for both measurements.

If it helps, maybe I can obtain a more precise measuring device from work...

Best regards
Martin

Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Tue Jun 21, 2016 9:28 am

That's plenty accurate enough to say that the temperature error isn't due to an incorrect voltage from the regulator...

I'm rather puzzled as to what's going wrong to be honest... I'll have to do up a modified version of the firmware for you and see what difference that makes...

User avatar
MartinB
Posts: 14
Joined: Sat Jun 18, 2016 8:46 am
Contact:

Re: Temperature reading off - calibration possible?

Postby MartinB » Tue Jun 21, 2016 12:34 pm

Mark,

I really appreciate what you are doing for me and for the project. Thank you very much indeed!

Please note, that I will be on a buisness trip from Wednesday till Friday - so I am available for further tests after that.

Best regards
Martin

Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Tue Jun 21, 2016 10:11 pm

OK, no worries.

I'm fairly busy at the moment, so I probably won't get a chance to work on the firmware for a few days anyway.

peterc
Posts: 13
Joined: Wed Jun 29, 2016 2:03 pm

Re: Temperature reading off - calibration possible?

Postby peterc » Wed Jun 29, 2016 2:11 pm

Hi Mark, I have the same issue. I just got two units from Paul. One unit (for both channels) is showing around 25C while the other unit is showing 42C for both channels. This is at start up with no charging process going on. 3.007V from the 42C unit, 3.003v from 25C unit. Would love to get it fixed! thanks!

Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Thu Jun 30, 2016 12:10 am

OK, I'll need to work on this ASAP - I'll try to get it done today for both of you.

Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Thu Jun 30, 2016 1:32 pm

Sorry I didn't get a chance to work on this yet again.

I did talk to Paul via email and he thinks that it's possible that some different temperature sensors might have slipped in on some chargers - I've asked him to check the self test logs to try to work out the range of serial numbers affected so that I can create a new firmware version which automatically adjusts the multiplier for the affected chargers.

peterc
Posts: 13
Joined: Wed Jun 29, 2016 2:03 pm

Re: Temperature reading off - calibration possible?

Postby peterc » Thu Jun 30, 2016 1:59 pm

thank you for taking care of this, now, i don't have to fake a higher temperature limit, haha

User avatar
MartinB
Posts: 14
Joined: Sat Jun 18, 2016 8:46 am
Contact:

Re: Temperature reading off - calibration possible?

Postby MartinB » Thu Jun 30, 2016 9:08 pm

Hi Peter,
glad to hear that I'm not the only one with this issue.

BTW: I noticed, that the color of the two LEDs (those blinking
while traffic goes over USB) is slightly different for both
chargers. I'm not sure if this means anything - probably the
parts are just different. But it could be a hint if it is the same
for your chargers?

Thanks again, Mark, for taking care. Please let me know
if I can do anything to support you.

Best regards
Martin

Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Fri Jul 01, 2016 12:56 am

Peter and Martin,

Can you provide the serial numbers from all of your chargers please? It sounds like you have each received a pair of chargers that weren't made at the same time...


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest