Temperature reading off - calibration possible?

For general discussion of the UltraSmartCharger
Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Fri Jul 01, 2016 2:28 am

OK, I've just uploaded a modified version of the firmware to fix this - you can download it from here:

http://www.ultrasmartcharger.com/TemperatureFix.zip

To use this version, you need to unzip the above file, start a command prompt and run the doflash batch file, passing the COM port to it - e.g.

doflash COM1

Before running the above command, you will need to bridge the pins just to the right of the FTDI chip - just slightly to the left of the positive terminal for the second channel.

Sorry again for the delay in getting this done for you both.

If you run into any problems, please let me know!

peterc
Posts: 13
Joined: Wed Jun 29, 2016 2:03 pm

Re: Temperature reading off - calibration possible?

Postby peterc » Fri Jul 01, 2016 1:57 pm

Hi Mark, just updated it. now its showing 1.5degC and 0.5degC, the other unit is still around 24degC.

Mark
Site Admin
Posts: 415
Joined: Sun Jul 28, 2013 6:47 am
Location: Brisbane, Australia

Re: Temperature reading off - calibration possible?

Postby Mark » Fri Jul 01, 2016 6:06 pm

Oops - sorry!

Can you try downloading it again and see if it works correctly this time?

peterc
Posts: 13
Joined: Wed Jun 29, 2016 2:03 pm

Re: Temperature reading off - calibration possible?

Postby peterc » Fri Jul 01, 2016 6:33 pm

it worked! 22.9 and 22.4C at ambient. you are awesome! :)

User avatar
MartinB
Posts: 14
Joined: Sat Jun 18, 2016 8:46 am
Contact:

Re: Temperature reading off - calibration possible?

Postby MartinB » Fri Jul 01, 2016 9:11 pm

Hi Mark,

it doesn't work for me:
msg.png
msg.png (4.44 KiB) Viewed 3174 times

It says "programm cannot be run, since libusb0.dll is missing". I shall try to reinstall it (?!)

Not sure if I can find the .dll anywhere on the web ... but I'll try.
I guess it is related to the Arduino IDE?!

BTW: what is "USCFWUpdate900.exe" for? I thought it would be just for something like this?

Best regards
Martin

User avatar
MartinB
Posts: 14
Joined: Sat Jun 18, 2016 8:46 am
Contact:

Re: Temperature reading off - calibration possible?

Postby MartinB » Fri Jul 01, 2016 10:05 pm

I googled "avrdude libusb0.dll".
Lead me to https://sourceforge.net/projects/winavr/.
After installing WinAVR the missing dll was there.
I did exact as Mark had told and this time it worked.
(Glad that Paul left a hole in the acrylic case to allow for the bridging -
my first thought was that I need to remove the cover)
Reading is now at room temperature around 21°C.
I'll post a follow-up for more exact readings.
Last edited by MartinB on Fri Jul 01, 2016 10:35 pm, edited 1 time in total.

User avatar
MartinB
Posts: 14
Joined: Sat Jun 18, 2016 8:46 am
Contact:

Re: Temperature reading off - calibration possible?

Postby MartinB » Fri Jul 01, 2016 10:34 pm

Before:
1.png
1.png (26.82 KiB) Viewed 3174 times

After:
2.png
2.png (24.1 KiB) Viewed 3174 times

(Datapoints in the attached .xls)

I would say: a pretty good match now.
Problem solved. Good job, Mark!

Thank you very much again!
Attachments
Temperature-Test.xlsx
(20.21 KiB) Downloaded 76 times


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest